Jump to content
 
Search In
  • More options...
Find results that contain...
Find results in...

WATCH TCM APP WORKING, BUT NOW I CAN'T SIGN IN WITH MY TV PROVIDER?????


Recommended Posts

Okay now Watch TCM App working, but when I got to sign in I can't because my TV provider isn't coming up on the list.  Now I have been watching for months with the same provider, but now not participating????  So I have TCM at home on my cable, but I still can't use the Watch TCM App????  This is so wrong!!!!  TCM says it has to be a provider on their list?  Where's the list???  It was on the so called list, but now since the build and only as of today it isn't anymore?  Someone stop screwing things up and fix the App!!!!  How am I getting my Watch TCM App privileges back now???  Help!!  I need my Watch TCM!!!!

Link to post
Share on other sites

Okay, I can watch on my PC, but can't activate thru my Roku.  The whole activation process is messed up because no one can get passed the first step with the provider.  No providers come up at all so you're just stuck at the first step.  Please someone fix this!!!!!

Link to post
Share on other sites

Yes, I have been having the same problem too. The Watch TCM app for Roku is the worst one I have encountered. I often wonder why TCM can't create a working app when it seems like every other network can. The Watch TCM app often fails to load. When it does load, there are times when it forces me to reactivate the app. This weekend, when I try to watch TCM through the Watch TCM app on my Roku, I am directed to reactivate the app. When I go to tcm.com/activate, I am prompted to select my provider from a blank pop-up window.

Roku-Activate-TCM.jpg

I should see a pop-up window with a list of providers to choose from. As you can see here, TNT has managed to do it correctly. Is this really so hard for TCM to do?

Roku-Activate-TNT.jpg

Link to post
Share on other sites

Thank you so much for reassuring me that the problem I am having is REAL!!!!  That's exactly what I am encountering just what you displayed above.  Just want them to fix it and fast.  It can't be that hard to do with someone with programming skills.  It should've all been done when they did the upgrade or build for Roku as they did on March 14, but obviously whoever did it didn't follow thru and actually test it.  This was done half a__ed most people would say.  Just get this done TCM!!!!!!!!!!!!!!!!!!!!

Link to post
Share on other sites

My Roku did the same thing. I had to put in a new code, even though it did not look like the Watch TCM app updated. Got the very same blank screen with no option of providers. Yep, BAD TCM!

EDIT: Roku Express and Roku Streaming Stick. Both get the blank menu with no options.

Amazon Fire TV Stick gave me trouble too. Did not get primary list of providers. Had to scroll all the way to the bottom for Xfinity. Did log in and all seems okay.

Link to post
Share on other sites

Normally I would consider multiple posts on the same topic spam but anyway I found what maybe a solution to those having difficulty registering their ROKU devices.

I had the same problem.

This worked for me.

After entering the activation code on www.tcm.com/activate, I found instead of clicking on the ROKU choice I chose the Amazon app instead and that showed a selection of TV providers unlike the ROKU which was blank, I selected my provider from the list and low and behold the TCM app on my ROKU was activated. Worked in my case, hope it helps you. YMMV

Link to post
Share on other sites

From the day it was introduced on the Roku platform, the 'Watch TCM' app didn't work for me...until yesterday.  I think there was an authentication glitch between the app and my tv provider, which is Google Fiber.  I also tried to use the app on my iPhone, to no avail, but maybe the process of authenticating on that device made the app work on my Roku?  It was a maddening process, but I'm happy to finally have TCM on my Roku...

Link to post
Share on other sites

I just started having the same problem with the WatchTCM app yesterday. 

The app was working fine on my iPad (new in 2018), with my provider, Spectrum. Now, it’s nothing but problems. I have deleted and downloaded the app several times, several different ways. (And I’m at home, using our own secure network.)  The app downloads, prompts for the cable provider, I select Spectrum, and . . . nothing. Nothing but trouble. 

Ironically, the app continues to work fine on my iPhone. 

Link to post
Share on other sites
  • 8 months later...
  • 1 month later...
  • 4 weeks later...

I am having problems watching TCM also. In order to put the activation code in the form it won’t show up. I have asked so many people to help me and they can’t help me to sign in either. Why is this happening.  Is TCM stopping their app.?  How do I get in touch with TCM?  They have some questions to answer. Maybe their cost is going up. 
I was watching the channel one day and the next day, poof, it’s gone. 

Link to post
Share on other sites

Is the Watch TCM App still active? Suddenly both my Roku devices required me to reactivate with the provided code. I did that and the website indicated it was successful. When I attempt to watch a movie I get a message "We apologize for the inconvenience, but the requested title is not available at this time" Watch TCM email support suggested remove and reload app and reboot devices, which I did, no change. I then loaded the app on an Amazon Fire TV stick and activated that device successfully and I have the same issue.

My service provider, Cox Communications, says all is well on their end, talk to Watch TCM support. The introductions stream fine on all three devices. Watch TCM support does not respond to my requests. Anyone have any ideas?

 

Link to post
Share on other sites
  • 1 month later...

I have ATT U-verse. I tried watching some programming on TCM app, through my Fire Stick but I keep getting an error message. Nothing will play.  So I tried the Watch TCM app on my web browser and it says that it can't verify my account.

What's the deal here?

Link to post
Share on other sites

Got this from TCM support (I'm having the same issue on the iPhone app that I downloaded right after I got this email so it's not just the firestick):

Hi there,

Thank you for reaching out to TCM. We're sorry to hear that you're experiencing issues with the TCM app.
Please note:

  • You must receive the TCM channel in your cable/satellite subscription package through a participating TV Service Provider in order to use the Watch TCM app.
  • The FireStick is NOT supported for the Watch TCM app.  Note it says here that the stick is NOT supported...then in a number of other places they tell you where to go on the FireStick.


Below are a few basic troubleshooting tips for the FireTV that may help resolve your issue.
 

Step 1: Update your software

  1. Make sure you have the latest version of the Watch TCM app. On your Amazon FireTV, move the selection to the Watch TCM tile and press the Menu button on your remote (appears as three lines). In the lower-right corner, choose More Info and then Update (if an update is available).
  2. Make sure you have the latest system updates on your Amazon Fire TV. To do this, go to Settings > Device > About > Check for System Update.

 

Step 2: Check your network status

If videos frequently buffer or are poor quality, a slow or inconsistent network connection might be the cause. To check your network status:
 

  1. On your Amazon FireStick, go to Settings > Network.
  2. Press the Play button on your remote to check your network status.

 

Step 3: Restart your devices

  1. Unplug your Amazon Fire TV, Fire TV Stick, or Fire TV Cube.
  2. Unplug the power from your network devices (modem, router, etc.).
  3. Wait 30 seconds.
  4. Reconnect the power to your modem and wait for it to connect to the Internet (about a minute).
  5. Reconnect the power to your router and wait for it to connect to the Internet.
  6. Plug your Amazon Fire TV back in.
  7. Open he Watch TCM app and see if the problem is resolved.

 

Step 4: Clear app data

  1. From the Home screen, choose Settings > Applications > Manage All Applications.
  2. Select Watch TCM from the list of apps.
  3. Select Clear data, and when prompted choose Clear data again.
  4. Restart your Amazon Fire TV.
  5. Open the Watch TCM app, sign in, and see if the problem is resolved.

 

Step 5: Uninstall and reinstall the Watch TCM app

  1. From the Fire TV Home screen, choose Settings > Applications > Manage Installed Applications.
  2. Select Watch TCM from the list of applications.
  3. Select Force stop.
  4. Select Uninstall.
  5. Download and reinstall the Watch TCM app from the Amazon Appstore.



We hope this guide resolved your issue, however if you are still unable to access the Watch TCM app, please let us know, along with the following information.

  1. Please confirm that you receive the TCM channel in your cable/satellite subscription package.
  2. Who is your cable provider?
  3. What is the make and model of your device?
  4. What OS are you using?
  5. Are you using a VPN to access the internet?
  6. Are you using a Wi-Fi or cellular connection?

 

Sincerely,
Your friends at TCM

Link to post
Share on other sites
  • 2 weeks later...

I was able to sign into DISH in the past, but cannot now.  I am using Safari browser.  I am trying to mirror from my MacBook Pro to my Samsung Smart TV.  What a hassle.  I have tried Chrome browser, but it doesn't allow me to access my apple play.   I  logged into Watch TCM on Safari and accessed mirror Apple TV and then I switched to Chrome browser and logged into Watch TCM and was able to mirror my movie to my Samsung tv.  I got it to work, but it seems like a round about way to accomplish this.  Why the hell can't the developers of this soft ware make it user friendly for us senior citizens?

 

Link to post
Share on other sites
  • 3 weeks later...

Iphone TCM not working. App loads and displays some movies. I select a movie and get a list of providers. I select " Spectrum" and get a blank screen. All other choices yield a login screen.

Occurs on my iPhone and also my wife's I phone. We can watch TCM on our TV's channel 82. Re down loaded the APP yesterday, but it did not help.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
© 2020 Turner Classic Movies Inc. A Time Warner Company. All Rights Reserved Terms of Use | Privacy Policy | Cookie Settings
×
×
  • Create New...