Jump to content
 
Search In
  • More options...
Find results that contain...
Find results in...

tcm watch now not working


Recommended Posts

I can't get watch now to work on my pc. I click on what's showing but it just shows the title screen then goes black and doesn't play. i've tried both ie and firefox. I have the latest versions of both and also the latest flash player. I'm using vista 64. Has anyone else had a problem watching? How was it solved?

Link to post
Share on other sites

I have been having problems with it also It used to work on my Nexus 7 and then when my Nexus updated it now crashes every time I go to play a movie on the Watch TCM app. It still works on my lap top. The movie Private Lives will not work at all on my lap top and I love that movie and have not seen it in a long time. The TCM logo re loops over and over. I e mail TCM and they e mail me back and say they will let their tech dept. know and that is the last I hear from them and nothing gets fixed. I feel your pain. My lap top has ie and firefox and it works on fire fox. I also have flash player the latest version and am on Windows 7. I am wondering if it's Vista 64 that may be your problem I love Watch TCM but it has a lot of bugs that are not being solved. Good luck.

 

Edited by: ConnieBennett on Jan 25, 2014 8:25 PM

Link to post
Share on other sites
  • 2 weeks later...

I just tried TCM Watch Now today. With Chrome, I have the same problem of being looped back to TCM without being able to see or sign-in with the Charter account. With Firefox and IE I can see and sign-in at the Charter account and after that it sends be back to TCM but the movie does not play - just a black screen. I tried TCM Watch Now on my Android phone with the same Charter account information and it works perfectly!

 

Interestingly, with Chrome while cannot even get to the Charter sign-in screen I can get to the AT&T sign-in screen, but I am not an AT&T customer. I hope someone at Charter or TCM resolve this problem.

  • Like 1
Link to post
Share on other sites
  • 2 months later...

I'm using a Surface Pro (Windows 8.1) with Explorer as browser.  I can get the movies correctly, but the Private Screening with Osborne and Baldwin only brings up the audio. 

 

It has to be a problem on who it is on the site, right?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
© 2020 Turner Classic Movies Inc. A Time Warner Company. All Rights Reserved Terms of Use | Privacy Policy | Cookie Settings
×
×
  • Create New...