Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

TCM and Linux MInt17 issues- Fullscreen Playback


Recommended Posts

I love TCM-it has grown into an excellent entertainment site on my Windows 7 machines ,even on the Win 10 preview machine-so I am not in crisis over missing movies

However, I am getting all kinds of hassles on my Linux Mint17.1 ATI driver equipped machines. they are certainly powerful enough, and set up properly, according to the forum suggestions via Mint

I build computers as a hobby, so have lots of them hanging around and even set up 4 separate computers and laptops in slightly different configs to try to figure out how to get full screen , no hassle, every time ,with a few clicks to get at the On-Demand movies. I have little interest in watching he Now Playing on computers these days ,though can see the need were i out more than I am these days

I use Wine in conjunction with Adobe and pipelight in this particular machine and play the small screen no ptoblem as Adobe probably isnt really loading . but as soon as i try to make the full screen (the browser is fine in full screen , just referring to the movie area- i get port 80 error 503 which is a generic thing, or a Sync issue.

I believe these issues are on my end,almost certain

but I was just looking for any other Linux users to see if they have encountered similar events and , if so how they fixed it

I am currently trying to use the Apache server and port sharing or allocation whatever it is called to configure it differently. I have no ideas of my own, just use google a lot and spent , now. over 3hours trying to make a 70min movie play in full screen "Airforce"

makes little sense since i could have watched it a few times by turning on my Windows pc

I will share any info i stumble across as i know there are many TCM fans who use linux in many distros and are frustrated. some have achieved success i guess, but i can find any

I can play all other video streamng web sites which is why i pursue this here. I play any and all youtube and even got netfix to play , until I dropped the service last year because I lost interest in the content they moved to , though i liked  , loved , the original stuff they had.  left after 8yrs or more

another story


Link to comment
Share on other sites

Thanks for the welcome, again

I am just hoping someone else has experienced this and found a solution.

I look everywhere any search engine takes me with those arguements above

I have tried everything i find and more , as noted in orig post

I watch TCM all the time=now

If i can get it working on Linux Mint17.1Mate,  in particular, but any Ubuntu,Mint, i would be happier than i already am

LInux Mint is fun and everything works, but this-for me. MeTv works, YouTube works, OTA TV though a usb digital stick 10yrs old works, just cant get TCM to work and i do not think it is Turner web site issue, unless indirectly somehow

 i can sign in to the OnDemand and Live no troubles, the java whatever works, but, no movie starts up in Chromium or in SeaMonkey at all and Fox Fire 37 it plays in the small inside the browser window ok for a few mins, but then if i try to go full screen , dead in the water. every time, never did try to watch more than 5mins in a small size , not really worth it . If i get bored, i might let one play to see if the small non expanded movie window will last the whole movie.


Link to comment
Share on other sites

  • 2 weeks later...

You're welcome John. Wish I could be more helpful about this subject, but I am afraid I can't. Hopefully someone else will come along and address some of your points in greater detail.

SEEMS I am the prime interested party in this issue, however:

i did find a fix for this and have just made one of my 'spare parts' newly built total linux Mint 17.1 MATE computer.  a nice streamlined and highly functional alternative to windows7 with only one drawback for me, did not play turner classic movies dependably and never in full screen

I did work out how to set up pipelight and silverlight with appropriate plug ins. and made sure to update them and specifically input the x64 flash. that among one or 2 other mildly complex command line entries makes it go in full screen too.

that is it for now. no idea if flash updates or if i need to keep an eye on this 'manually

will get back to post changes, in case anyone is intersted other than myself , that is

i will provide all details upon request, though

Link to comment
Share on other sites

  • 4 weeks later...

Here's how I watch TCM On Demand on my Fedora 22 Linux Thinkpad T61 laptop.  TCM's FAQs say that it will only play on Windows or Apple OSes.  What I did first was install Wine on the laptop and then install Firefox via Wine.  This appears to be a Windows system to outside websites and I was able to sign into TCM via my VerizonFiOS account and watch TCM movies full-screen after installing Flash as well.  The one problem was there was no sound.  More research yielded two possible front-ends for Wine that I could try.  First I installed CrossOver from CodeWeavers.  This costs $59.99/year but for two weeks you get a trial version.  With Crossover, I was able to install Firefox and Flash.  I could watch movies and hear them too.  It worked!  But, I didn't want to pay so I tried a PlayOnLinux which is a free front-end.  This worked too and now I can watch the movies and listen to them on my laptop.

Link to comment
Share on other sites

  • 2 weeks later...

thanks to hal for posting his Wine and fedora method. fedora is a good version of linux and can do lots of things plus has a good support network through forums . i read some and some works in my MInt 17.2 now. started with just mint17 11months ago. I have not been able to get the wine connected firefox to work out, nor the wine installed IE either. probably something i am doing improperly.  I follow the directions and command line entries. get them up but still no luck with the playback plus, they use a lousy system of font rendering despite my attempts to modify that via forum suggestions

the issue is only a playback of tcm on one linux mint 17,2 mate set up. the same basic set  up as the laptop and linux only computer which play back tcm and everything else just great and all the time.  I am still trying to track down why my newest and supposedly best computer with linux in it stopped being able to play back tcm. i had it working for a time and it worked each time for a couple of months , maybe 2. or less, until this month July, when it began to just spin the wheel again. the flash allows the sign in part to function but refuses to play back. i have to track this down again,but, as  i have noted before, i had learned so many different ways to make flash , silverlight, html5, pepperflash/pipelight plugins to get you tube or me tv and turner movies that i am not sure what one is actually working or not working , updated or not, plus the wine options either in wine alone or just the smooth wine assisted interface.  may be just as simple as to white list turner on adblock, which it is , but just as simple. in the end

just adding this here in case anyone with linux and tcm issues might scroll by to see. TCM on demand and live does work in linux and seemingly out of the box linux mint mate in particular. those 3 systems are just fine still and so far. just my favorite one,  which is also the one i did lots of additions to, causes me some issues.


edit PS:

half hour after posting this I was able to get the one TCM on linux to play back and play back in full screen as well. NO clue as to how or why. I fiddled with enabling /whitelisting/disabling the Ghostery and AdBlock and ABE pop up options to no avail. no matter on or off, still only spun its wheel. I enable /disable command line terminal entries in linux for pipelight plugin and flash, flash x64 too. and then just blocked flash in the address bar icon -which totally removed all signs of life on the page. cant sign in nothing. so i rebooted friefox and then moved up to the address bar flash icon and 'allow now' and all of a sudden the live item that had been on prior to reboot started to play as it should and had been. probably wont after a boot. hopefully , it will again allow the opton to enable that flash, whether it is a pipelight flash or a windows/wine version which i suspect it is(wine) dont know nor do i know how to make this process happen each time. seems to be hit or miss. whether wine tricks loads or not. it is supposed to, but, whio knows

that is it for now.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

© 2022 Turner Classic Movies Inc. All Rights Reserved Terms of Use | Privacy Policy | Cookie Settings
  • Create New...