Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Anyone else having problems with the TCM ON DEMAND?

Recommended Posts

I have sent TCM several emails but have never EVER received a specific or timely reply whenever I have attempted to communicate with TCM using their "Contact Us" via email.


Hopefully someone here is familiar with the TCM MOVIES ON DEMAND app foibles and will be knid enough to enlighten me with a response.


As of this year I have began using the WATCH TCM ON DEMAND app.

I find it handy when traveling, and also, when at home, as I no longer have to worry about a cable glitch when using the app, and I can watch "most" (but not all) TCM movies at my leisure up to 7 days after airing. That has been a very good thing.

BUT, I have queried before with NO RESPONSE from TCM, that there is no way for an app user to know ahead of time which movie that TCM airs that will actually be available for later ON DEMAND

viewing until AFTER they have been aired. Surely the folks at TCM know this ahead of time?

It would be very nice if there was some advance notice provided on the schedule as well, so those of us using the app would know in advance which movies we will be able to watch later on the app, and which that must be watched only during the "Live" broadcast.

Would be really considerate if someone at TCM addressed this concern, and let us know somewhere on these boards about it.

Now, to my immediate frustration and the reason for this thread...


Late last Saturday night (11/7/2015) the TCM MOVIES ON DEMAND ALL MOVIES title list vanished from my PC screen. Well, not totally... the TCM logo page is still there, but the MOVIES ON DEMAND Movies List for the previous 7 days is now blank?

I now have no way to select movies to watch using the app from up to 7 days prior....

The current & previous days Schedule is still there. But no longer are there any movies listed or their images?
I don't know if I have somehow inadvertantly filtered the list out? or if TCM is having an ongoing problem with the ON DEMAND page that is not yet corrected. Or if there is some other issue going on.
There were some movies on the schedule that I wanted to watch and time (the 7 day limit) is quickly running out...


Contact TCM has no specific "drop down" "category" for email queries addressing their MOVIES ON DEMAND, and though I've shotgunned my concerns to several of their "categories" TCM has never, EVER specifically replied to a single email that I've ever sent them in the past, and not likely to change their ways at this moment....

Could, Would someone at on the TCM boards that is familiar with the TCM ON DEMAND app, please send me a prompt email reply regarding this latest issue.


Please check (preferably using your PC) and see if the TCM MOVIES ON DEMAND ALL MOVIES title list is visible on your PC screen and let me know.

That will tell me whether this is an issue that everyone is experiencing, or just a problem that I may be having for some unknown reason?

Thank you (whoever you are) for taking the time (hoping that you do) to reply back to me.


BTW, I inadvertantly started this thread in the "Information Please" & General Discussion boards,






but perhaps this is a better to ask. I have already received a couple of replies but my current problem remains unresolved hoping that somebody here might be able to offer a suggestion or two as to why I can no longer view the ALL MOVIES title list?

BTW, my cable provider is COX if that means anything?

Oh, and my PC uses Win 7 pro 64 bit OS, if that is helpful to know?

Link to post
Share on other sites

I found a work around to be able to still locate the movies on the app that I wanted to watch. A bit cumbersome, but it worked.

After watching a couple before they expired, I noticed that the missing film images were back up and when I then clicked on the ALL MOVIES button... low and behold the title list "magically" became visible again.

I've a sneaky feeling that the problem was with my cable provider (COX).

I did nothing to make the list go away, and did nothing to make it reappear. After a two 1/2 day hiatus, it magically just "fixed" itself.

Not.... but I can never get my cable provider to admit that they are at fault with anything....


Figures I'd post the issue here and within a few more hours the problem would "correct" itself.


Anyway, I appreciate the kind support provided by my fellow board members. That is the only support that I have received. Nothing from TCM nor my Cable provider, so thanks guys. :)

Link to post
Share on other sites
  • 1 month later...

UPDATE to my Original Post/s


I have read through most of the threads in this section and have come to the SAD conclusion that TCM is totally deficit in providing any kind of support to their viewers regarding technical difficulties with their highly promoted WATCH TCM ON DEMAND App!


I HAVE NEVER received an email reply from anyone at TCM regarding any of my queries, and I see that I am far from alone here.

Whenever I have called them likewise no one ever picks up or calls me back.

I do see on a very few occassions that Moderator One has made a response within a very few of these threads, but evidently nothing positive has resulted from that.


When I first started using the WATCH TCM App earlier this year (2015), I was generally pretty pleased.

There were a few issues of concern, such as the occassional "cut short" movie (when a movie was broadcast with a run time "short" of the complete movie), and not knowing which movies would be available to view later on the App (before they were aired "live").

But at least then the WATCH TCM App actually worked on my PC using Win 7, with Iexplorer 9, and (compared to the problems of others and to what I am now experiencing), I realize that then I really had no "major" issues to complain about.

That was until somebody at TCM must have made some kind of "upgrade" to the App in early November 2015 that wasn't compatible with my system set-up and caused the listed movie titles to disappear.

It was then when my (lack of TCM support) frustration level grew to the point that I started this thread.


The movie title list would occassionally and "mysteriously" reappear and then disappear again, and for the most part this month it has rarely shown up. So using that feature with Iexplorer has been a bust.


I did discover a somewhat cumbersome "work around" to watching movies using the APP though that I have been using since November. That was simply typing in Title in the SEARCH in the upper right hand corner of the page, the movie would "sometimes" show up and allow me to watch it.

There are flaws with this "work around" because the App search engine doesn't recognize apostrophies, and certain title idiosyncrasies, so one must try different search variations, and even doing all that, some titles that really are there, won't show up at all, regardless.

The only way to narrow the title search down to those that are available for later viewing is to religiously use the day and previous day schedule. Also I have discovered that for some reason when using Google Chrome the title list pops up like it should, though when attempting to use Chrome to watch I repeatedly get a SAML error when trying to verify my COX account.


So I can use Chrome to verify what's available on the App, but must use Iexplorer and the App SEARCH engine when trying to watch something.


So this has been my mode of operation throughout November and most of this month.

Then TCM began promoting a "New" "Improved" App????? (Again... this month) and whatever they did, has only screwed my viewing with the App up even more than before.


Starting around the 2nd week of December 2015, in about 2 out of three attempts to watch a movie using the APP (even when I can get it to load), the movie will freeze somewhere during the watch. Generally the audio begins to stutter first followed by a frame freeze, then I get a message that the TCM signal is no longer available and Iexplorer has failed.

I can restart, reenter my COX verification and start watching over again. But the problem may or may not occur again and again.


Another issue is that despite signing in to COX the App requires me to sign in again, and again,  about three out of five times whenever I re-search either the same movie, or a different movie.


I have only tried watching movies using the TCM APP on a PC (sometimes connected to a big screen monitor) and I have only been using Win 7, Iexplorer version 9, or Google Chrome.


I see many here actually use various portable electronic devices for viewing TCM and there appear to be numerous problems across the board with many of them.  All which remain unaided by anyone from the TCM technical department.


My experience with my system watching movies on the APP has been quite mixed.
When I can get everything to work "right" that is.


My system is a high end laptop PC with an I7-4910MQ CPU, onboard HD 4600 graphics, and an  independent high end Nvidia Geforce GTX  980M graphics processor, plenty of VRAM and 32GB on board RAM. A High Def 18" 1080 monitor.
And using Win 7 (64 bit) OS, and Iexplorer 9, or Google Chrome web browsers. 


At home my WiFi download has been a pretty consistent 5-6 Mbps using Wifi (generally 3 Mbps or faster has been good enough for NetFlix on-line movie viewing) and the ethernet Broadband has been a pretty consistent 15-17 Mbps.

So the Connection speeds should not be a factor.
Also, I only attempt to watch TCM with the App when nobody else in the house is using WiFi.  

When using WiFi I found the system would occassionally, annoyingly, buffer, sometimes only once, sometimes repeatedly (evidently the TCM App internet speeds must be much more demanding than NetFlix), so I began experimenting using an ethernet cable connection with broadband to see if that made a difference. 


When viewing with an 18" PC monitor or on a much larger screen the quality varies considerably.
A few of the APP movie downloads have been equal to DVD quality, but most of them are not.
I have also noticed that whenever there are rapid scene changes, or fast action that the image most often deteriorates. This happens inconsistently though, as in a few movies whether black & white or color, the image quality has remained constant.

These image problems become less noticeable on much smaller screens, and movies are perhaps best viewed on screens screens 7" or less. So image inconsistencies may also be more pronounced on a larger screen Ipad. 


Also, for some strange reason, several of the TCM movies have been broadcast in annoyingly tiny Windowbox format.


At this point I do not see the APP replacing TCMs live subscriber service anytime soon.


There are many, many variables, any of which could either be the singular cause or compound the many problems expressed by myself and other posters on these boards.


-There is the internet provider (in my case COX), some of which are notorious for bad service and even worse support.
-For WiFi especially, download speed can be affected by high traffic times in an area, which would generally cause lower speeds below minimum thresholds, and increased buffering .

-There is a host of different portable devices using a variety of configurations which interact, or NOT with the TCM App.
-These include a variety of browser version issues, types of Antivirus and AntiMalware protection, and level of security chosen by the individuals, including acceptance of third party cookies, etc. 

-AND finally we have the various renditions of the TCM App itself.

Evidently the TCM App is/has been under constant revision, which can explain why what once worked for some of us no longer does.


However most of these issues could be more easily addressed IF ONLY TCM APP designers/promoters would COMMUNICATE with US, the USERS.

I have absolutely NO idea what the APP requires to function as it should. What OS it works best on, what Browser version is most compatible. How weak and vulnerable must I make my system to allow the APP to perform.

I have been unable to find ANY of this information on these Boards, and of course, NOBODY at TCM responds to ANY of US when we cry out for help here.


In spite of its current flaws, when working one can become easily accustomed to the convenience of a seven day viewing window for at least most of what TCM broadcasts live.

HOWEVER, at this state of NO ONLINE SUPPORT from anyone at TCM I caution ALL APP users to BEWARE.

What works today, may fail tomorrow, and when it does, you will be left crying in the dust by TCM.


UNLESS TCM chooses to address our concerns, as most any responsible company would (or should) I would stay away from using the WATCH TCM ONLINE APP, or at least approach with grave caution.


For me the WATCH TCM App appears to be a very poor release (and each "revision" brings it's own "can-of-worms" to the table).
It's certainly NOT (in it's current state) worthy of such great promotion hype.



For ALL of the Above reasons (and especially the last), the TCM App reflects poorly on TCM as a whole.


Link to post
Share on other sites
  • 1 month later...

February 9, 2016 UPDATE


Well, I am somewhat happy to report that sometime between my last post Update and this Update, that TCM has included a Technical FAQs to their WATCH TCM Help page




Don't know when they did this, and they still have NOT responded to ANY of the emails sent to their CONTACT TCM (Lack of) Support Center. Nor calls, Nor hard copy letters mailed to them, So TCM is STILL NOT PROVIDING ANY KIND OF SUPPORT from that location, at all.




According to the


My laptop PC system far exceeds their minimum recommendations.

They say you need Adobe Flash Player with version 10.1 or higher, I had Flash Player 17 installed, so there should NOT have been any problem, but I went ahead and updated to Flash Player 20 anyway.


They say Internet Explorer 7 or greater or Mozilla Firefox 4 or Google Chrome web browsers should work.

Been using IE 9 (because I like it better than IE 11) still greater than IE 7, so that should not have been a problem (and wasn't until they introduced some WATCH NOW app revision last mid October which screwed it up since).


I have also been using the latest version of Google Chrome (ver 48.0.2564.109) but still receive the same unidentified SAML error when trying to verify my COX account.


Today I did download and install Mozilla Firefox 4 browser, and was pleasantly surprized to see that it at least provides the same abilities that IE 9 used to, so I can now use it to not only access what WATCH TCM has available, but can launch and view movies through that same browser as well.


So that is the only good news that I have recently discovered. For those experiencing problems with either Internet Explorer and/or Google Chrome, you may want to give Mozilla Firefox 4 a try.


They do now say that we need an Internet connection of 3.0Mbps or greater within the US.

When I was using WiFi and checked using my provider (COX) and http://www.speedtest.net/

my WiFi download speeds averaged between 3-5 Mbps, so that never should have been a problem, but still frequently encountered buffering issues after that October App revision.


I now only test the App using an Ethernet conection with a high end Motorolla Surfboard Modem SB6183.

My download speeds have consistently been between 15-17mbps.

No buffering, which tells me that if your download is at the 3mbps it is only marginal, and if it dips below that, either due to others on line at the same time within your household, or heavy local internet traffic, or if your provider speed waivers, and you dip below that 3mbps for whatever reason, you will likely experience those buffering freezes, and artifacts (such as sound garbling, etc.).
NOTE if you experience this with an ethernet connection on a modem that once worked well, it can possibly indicate that your Modem is beginning to fail, especially if the problem occurs intermittantly.

Only way to be sure is to have either a second Modem that you know works to swap, and see if the problem remains, Or have someone test your existing Modem for you.


As far as the other problems that I and many others have complained about, in particular the "fuzzy" or blurry, ever adjusting images when there is either fast action occuring on screen, or during a scene transition.
This quite frankly reminds me of a poor refresh rate problem. Though it does not occur for me when using the live cable feed on TV whether I'm using a standard 60Mhz refresh rate monitor, or a 120Mhz refresh rate monitor (NOTE I do not have anything that refreshes faster than that to test with). But because the problem only occurs with the WATCH TCM app, I feel certain that it is not my equipments fault. And since so many of us have reported this here, it is my deduction that there is a problem that likely originates with the TCM App delivery system (and the way it handles different movies), and may also be compounded by the providers inability to consistently handle it over the internet.

This Fast Motion blurring is, of course, most pronounced when using the App to view fast Action Movies, and less pronounced with other "slower" movie types. (i.e. very pronounced when horses or people, etc. are running, or moving quickly on screen)

One thing that I have noticed, which is peculiar, is that it may inconsistently occur even with these movie types (varies with different movies being aired) and also seldom seems to occur with foreign films that I've watched while using the app. ????

None-the-less, when it happens, as it frequently does, it makes viewing on anything larger than a 5" screen almost intolerable to watch. And I personally do not like to watch any movie on less than Full screen on my 18" Laptop monitor, or on my much larger TV monitors.


Other issues, such as tiny Window Box App presentations (Not seen when using the live cable feed on TV), and the occassional "cut short" movie (a movie that has an app. run time shorter than the actual movie's run time) are relatively minor annoyances compared to the major issues of getting the app to run at all, and then run well.


TCM is constantly airing promotions to use their "Newly Revised WATCH TCM App."

These revisions have been going on for a very long time now, and as I stated in my original post one of them destroyed the functionality that I originally enjoyed with the App. Nothing that they have done since has restored that. Nor the numerous incompatibility issues that others have complained about using their various devices.


Obviously, the App must be working well for those that designed it, and more than a few of the rest of us as well.

BUT the total disregard of TCM to provide a way to directly communicate with them so they can provide some kind of on-line support for this thing is (to me) dispicable. Especially with all of the on-air hype that they provide promoting it.

I honestly do not believe that Ben or Robert are even aware of these problems (at least I do not want to believe that they are).

But somebody at TCM should be aware that many of us are experiencing these problem issues, long before now. I know that the TCM Moderator 1, who occassionally posts here says that he or she has forwarded some of our concerns to somebody???
It seems incomprehensible that if those in charge of TCM were aware of the issues that we have so desperately voiced in these threads that they would continue to deliberately ignor them, and us....

But sadly, after all this, that is the only conclusion that I can come to... TCM management has made it consistently and abundantly clear that they have chosen to NOT PROVIDE ANY ONLINE SUPPORT for their WATCH TCM App.


For that reason alone I cannot and will not recommend the WATCH TCM app to anyone that I know and care about who otherwise loves TCM's programing.

The WATCH TCM app is clearly still too buggy and there are simply too many of us here (on these boards) experiencing unassisted problems with it. 


As I have said before and repeat again...  I caution ALL current APP users to BEWARE.

What works today, may fail tomorrow, and when it does, you will be left crying in the dust by TCM.

Because sadly, THERE IS NO ONLINE SUPPORT from anyone at TCM !!!

  • Like 1
Link to post
Share on other sites
  • 10 months later...

I had the same problem.  I use Windows 7 and the needed version of Adobe Flash would not update with IE, however once I downloaded Chrome (which I hate) I was able to get the correct AF version, but you have to use Chrome when you are viewing any program/channel that you want to watch using Xfinity, EPBFI and many other service providers.

  • Like 1
Link to post
Share on other sites
  • 3 weeks later...

January 11, 2017 UPDATE!


Well, I am sorry to report that I am again in the TCM ON-DEMAND doldrums.


And I again sent another email to TCM explaining the situation and asking for some assistance, but unless something has dramatically changed (for the 'better') I really do not expect that I will get any response back from anyone at TCM.


Here is my email, which I just sent.

Hopefully it clearly explains what is happening at my end of the TCM ON-DEMAND world.


Email to TCM "Support" 1/11/2017

I watch TCM ON-Demand movies on my PC. My OS is Win 7 pro (64bit) and have a high-end NVidia VGA card (with ample VRam, high-end CPU, and plenty (32GB) of RAM.
My cable & internet provider is COX and I use Ethernet connection for fastest & most consistent download speeds which is >5mbps (per speedtest.net)
Have No problem with any thing other than TCM ON-Demand movies.

My browser is Mozilla Firefox, and since October I'd been using v.47.0.1 and watching TCM On-Demand movies with no apparent problem at all!
Around christmas I updated to Mozilla v.47.0.2, and I began noticing occasional buffering issues when watching TCM ON-Demand movies on my PC. So I recently upgraded my browser from Mozilla v.47.0.2 to v.50.1.0, (and updated Adobe Flash from version to version
But when I sign in as usual, the movies never load or play at all! I receive no error msg from either TCM or COX, but according to the TCM panel I am not signed in?
I reloaded the earlier ver. of Mozilla (v.47.0.2) which is no longer secure, and I can watch TCM On-Demand again, although with those frequent buffering issues which began in mid Dec.
But when I reload Mozilla back to v.50.1.0, I am again unable to sign in to TCM and watch movies?
This only affects TCM On-Demand, as I can sign-in to the TCM message boards and post normally.

So there appears to be some recent conflict with the TCM On-Demand feature and this latest version of Mozilla Firefox web browser.
Mozilla v.50.1.0 corrects some Critical security deficits from the earlier versions, but evidently no longer gets along with TCM On-Demand for some reason?
Aside from reinstalling Mozilla v.47.0.2, (or earlier, unsecured versions), is there anything that can be done to allow me to watch TCM On-Demand movies with the latest versions of Mozilla (i.e. v.50.1.0)???

Please let me know if I can provide any additional information to help with resolving this problem.
Thank you for your time and consideration.
Sincerely, A Loyal TCM viewer.

  • Like 1
Link to post
Share on other sites

Stephan55 (or is it actually Norman?): Since the 1st of the year, possibly earlier, I have had a similar problem streaming "tcm on demand", and it occurs on all three major web browsers, so in my case the actual web browser is not an issue.  I don't think that tcm will ever respond to the problem, so I may need to find an alternative for classic movies.  It was especially bad when I tried to watch "Cool Hand Luke" two nights ago and "The Magnificent Ambersons" last night, well before the expiration date kicked in.  It will initially boot up and then a few minutes into the movie, the screen will suddenly go black.  After 10-15 minutes, I return and the movie boots up again but then goes black again.  Tonight, it's happening with "Tomorrow".  Instead of going black, this time I get the rotating circle.  I'm not sure if this has to do with an adobe upgrade.  I have Windows 10, unfortunately, so anything is possible.  Very frustrating and a very unpleasant viewing experience, but tcm apparently (1) doesn't care or (2) has no ability to remedy the situation.

  • Like 1
Link to post
Share on other sites

Stephan55 (or is it actually Norman?): Since the 1st of the year, possibly earlier, I have had a similar problem streaming "tcm on demand", and it occurs on all three major web browsers, so in my case the actual web browser is not an issue.  I don't think that tcm will ever respond to the problem, so I may need to find an alternative for classic movies.  It was especially bad when I tried to watch "Cool Hand Luke" two nights ago and "The Magnificent Ambersons" last night, well before the expiration date kicked in.  It will initially boot up and then a few minutes into the movie, the screen will suddenly go black.  After 10-15 minutes, I return and the movie boots up again but then goes black again.  Tonight, it's happening with "Tomorrow".  Instead of going black, this time I get the rotating circle.  I'm not sure if this has to do with an adobe upgrade I have Windows 10, unfortunately, so anything is possible.  Very frustrating and a very unpleasant viewing experience, but tcm apparently (1) doesn't care or (2) has no ability to remedy the situation.


Ha! No, it is Stephan... Norman is just my alter ego :)

I read the post in your thread where you mentioned you have FIOS (fiber optic cable), which is as fast and efficient as it can yet get, so that should certainly rule out most of the potential download speed snafus. Especially if outside checks such as speedtest.net verifies it...


Your experience is very similar to my own. With the prior version of Mozilla (v.47.0.2) reinstalled, I am again able to view TCM On-Demand, but only about 25% of the time without any issues. 75% of the time the video will begin and then do as you have described (screen black-outs & what appears to be buffering, i.e. "the rotating circle") somewhere during the viewing, sometimes repeatedly, and frequently necessitating one or more complete restarts to get the movie "moving" again.

This began for me around the middle of December 2016.


In early 2015, when I first started using the TCM On-Demand feature, I was using IE9 as my browser, and for almost a year I had no problems at all. Then in November that year IE no longer worked with the TCM On-Demand title schedule. I tried Google Chrome and could see the On-Demand titles fine, but received SAML error messages whenever I tried to log in to my account, so NO viewing with Chrome.

For awhile I used Chrome just to check the schedule and then would watch using the IE browser.

Another issue that cropped up around that time was "fast action motion blurring" in many, but not all, of the domestic movies watched. And strangely this did not seem to occur at all with the TCM import features.


In February 2016, I began using Mozilla as my browser, and have not looked back since.

It worked like IE used to for me. Another thing about that same time was the "Fast Motion Blurring" went away.

I think around June that year I noticed the big push for Win 10, and later discovered that MS had secreted Win 10 "upgrade" files on my PC. Did some checking and wanted nothing to do with Win 10, went to great lengths to get all of those files off of my PC, and then had to monitor for several months to make sure that they stopped reappearing. The whole situation alienated me from Microsoft and when they cease support for Win 7, I plan to be using Linux.

I also stopped using the Google search engine for privacy reasons, and now use DuckDuckGo (I know, it's a silly name, but they, like Mozilla, seem to put their users privacy ahead of marketing, so I support those policies and them both with donations from time to time, to hopefully keep them around).


I do not allow any "automatic" upgrades/updates on my PC, as I prefer to be notified and then check out what the "upgrade" is actually for. Generally, if it is for a bug fix that does not apply to me I will pass (a "luxury" no longer afforded to Win 10 users), as it's been my experience that sometimes an "upgrade/update" will introduce problems not previously experienced. This has been especially true for me with TCM On-Demand viewing.

However if there are Critical Security issues involved, then I am much more likely to accept certain updates or upgrades.


Since my last post have I've heard nothing from anyone at TCM (which doesn't surprise me).


I have communicated with COX tech support, explained the situation, and their conclusion is that since I have received no COX sign-in (log-in/turner...SAML) error messages that the most likely scenario is that TCM has not yet updated their On-Demand system to be compatible with the latest version of Mozilla.

This was my suspicion as well, but since I (we) can get no response from TCM at our end, I did ask if the COX tech could please forward my concern as a subscriber to TCM through their channels. She said that she would (for whatever that was worth), so hopefully, if TCM is unaware of this compatibility issue, someone will soon be informed and correct it ??????..... (well, here's to "hoping" anyway)


I have also submitted a "bug report" to Mozilla, so hopefully someone at their end may "also" address this issue in their next Firefox update.


In the meantime, for my latest work-around:

I created a separate Mozilla install in a slightly differently labeled folder of Firefox v.47.0.1 (this was the last version of Firefox that I used with TCM experiencing no problems at all).

I then created a separate desk-top short-cut for the .exe and labeled it for "TCM On-Demand Only!"

Because this version is reported to have Critical security issues, I want to hopefully minimize my risk by restricting it's use to just TCM On-Demand.

For all other browsing, etc. I am using the latest Mozilla ver. 50.1.0.

This way I can avoid the cumbersome deletes and reinstalls of either Firefox version, and just use them as totally separate browsers as needed.


 Using this older version "fix" allows me to again at least sign in and view TCM On-Demand movies, but unfortunately it hasn't remedied the problems with the screen black-outs & what appears to be buffering, i.e. "the rotating circle" that occur repeatedly in about 3 out of every four attempts to watch an ON-Demand movie.


The only other variable at my end was something that you mentioned in your post about an Adobe "upgrade."

In early last December I again began being annoyed with those reminders from Firefox whenever I signed in to TCM On-Demand, that I needed to "update" the Adobe Flashplayer on my system for "Critical" vulnerabilities.

So when I updated Firefox mid December, I also updated the Flashplayer from version to ver. After that is when the "black-outs" and "buffering circles" became endemic.

I tried to remedy both since with another update to the latest Mozilla ver. 50.1.0 and latest Flashplayer ver., but that combination kept me from signing in to TCM On-Demand.

Going back to an earlier version of Mozilla, remedied the "sign-in" part of the problem, but I do recall noticing the appearance some "conflict" messages coinciding with the screen black-outs, usually after repeated buffering.

I believe the msg was that Flashplayer stopped working because of a webpage conflict???? 

When watching TCM On-Demand, TCM is the only Webpage that I am using with Firefox, so this may possibly be the culprit causing part of the trouble.

I now hypothesize that TCM ON-Demand possibly has issues with both the latest versions of Flashplayer, beginning with ver., and with the latest version of Mozilla ver. 50.1.0???


The only way to confirm this would be to go back to an earlier version of Flashplayer, when the above problems did not exist.


This is a bit more cumbersome than having two versions of Mozilla in two separate folders, as I am unaware of a way to have multiple versions of Adobe Flashplayer simultaneously installed on my PC.

I would need to delete the current Flashplayer ver. and reinstall an earlier version of Flashplayer (i.e. ver., and see if that remedies the TCM On-Demand "black-outs" and "buffering" issues.

The pitfall of this is, if it does work, using an earlier version of Flashplayer places my PC at even greater risk when on line.

The only way to minimize that would be to constantly "re-update" Flashplayer for everything else, and then delete and reinstall the earlier Flashplayer version when watching TCM On-Demand.


I have accessed the Adobe Flashplayer archives 


and downloaded a couple of the older (now unsupported) Flashplayer versions (ver. from 10/26/2016, & ver. from 11/8/2016). Tomorrow I will begin to experiment and see if I can verify my/"our" suspicions. After a few days of viewing On-Demand, I should be able to make a deduction. 


If it does work, then this will be an even riskier "work-around," than my current flawed method at best.

However, in either event, I believe the actual problem "fix" rests with those "Techies" at TCM responsible for maintaining ON-Demand compatibility with the latest (and frequent) browser and Flashplayer updates.

It may be that those persons "in-charge" of such issues at TCM display the same level or lack of communication with their professional peers as they do with their subscribers, in which case, who knows when (or if ever ) TCM will decide to take up the reigns to remedy these problems at their end. 


Another interesting (or not) conundrum, is that while using the latest versions of Mozilla (ver. 50.1.0) & Adobe Flash player (ver., though I am unable to "sign-in" to watch an ON-DEMAND movie, the problem does not impede the ability to view all of the "clips & trailers" on that same screen. So it's not as if the Flash player won't play a video on TCM, and if the "sign-in" glitch can/will ever be remedied, then perhaps I'd have no problems at all with these latest updates????


All of this has done nothing to change my opinion that TCM ON-DEMAND remains too buggy to recommend to persons that you hope to retain as friends. As when it sometimes works, it feels great (for awhile), but inevitably it will fail you when you really want to watch something important to you, and leave you feeling very frustrated and dissatisfied.


I'll post again, after a sufficient "test" period, with the results of my experiment..... or if I experience any additional issues with TCM On-Demand using this configuration.

Link to post
Share on other sites

Recent UPDATE to Last Post


Shortly after I made my last post, and BEFORE I installed an older version of Adobe Flash player, I attempted to watch another TCM ON-DEMAND movie with the older version of Mozilla (v.47.0.1) and the latest version of Adobe Flash (ver.


I then experienced a fairly typical scenario....

After the movie "To Be Or Not To Be" played normally for a little over an hour, the little "buffer" circles began to appear, freezing the movie screen. After a few seconds, the movie continued a couple of times, but then the freeze remained...

I rechecked after about 15 minutes and the movie screen had "blacked out".


I then noticed the little bar above the blacked out screen which said:
"A Web page is slowing down your browser. What would you like to do? (buttons on the right side offered two options: "Stop It" or "Wait").
I clicked "Wait" and the screen remained frozen and the original message reappeared.
I then clicked "Stop It" and a different bar appeared stating: "The Adobe Flash plugin has crashed. Learn More.... and two buttons on the right offered to "Reload page" or "Submit a crash report".
Clicking "Reload page" just allows me to regain control of the webpage, but the movie screen still remains "black" or "greyed out", it does not refresh the Adobe Flash plugin, for that I need to close the the browser and reopen it, reload TCM On-Demand and start over again. with a fresh movie.
Clicking "Submit a crash report" hopefully sends the data to both Mozilla AND Adobe, however it will only show them that I'm NOT using the latest version of Mozilla (which doesn't allow me to sign in to TCM ON-DEMAND anyway...)
Clicking "Learn More" redirects the page from "Plugin crash reports" to this link


Send plugin crash reports to help Mozilla improve Firefox
(Redirected from Plugin crash reports)

This error means that a plugin (like Adobe Flash) has crashed. Simply reloading the page will restart the plugin, and your video (or other content) will be shown again. Before reloading the page you can add a comment to explain how it happened and send a crash report to Mozilla by clicking on Send crash report. These crash reports help us make improvements to Firefox.

What is a plugin?

A plugin is a piece of software that displays internet content that Firefox is not designed to display. This usually includes video, audio, online games and presentations that are made in patented formats. Plugins are created and distributed by the companies that make those patented formats. Some common plugins are Adobe Flash and Microsoft Silverlight.

What is a crash?

A crash happens when a piece of software abruptly stops working. Plugins sometimes crash for various reasons, and cause Firefox to crash along with it. For more information about Firefox crashes, see Firefox crashes - Troubleshoot, prevent and get help fixing crashes. Some plugins load separately from Firefox, allowing Firefox to stay open if the plugin crashes.

What information is sent in a crash report?

Crash reports only include technical information to help Firefox developers determine what went wrong, and how to fix it. These reports do not include personal information. The information sent in a report includes:

  • what webpage you were on
  • version of Firefox you were using
  • your operating system
  • installed plugins
  • installed extensions
  • and more technical info.

This information is subject to the Firefox Privacy Policy.

How do I keep plugins from crashing?

Many problems with plugins can be solved by updating to the latest version of the plugin. To check if any of your installed plugins are out of date, visit Mozilla's Plugin Check & Updates page. The name of the plugin that crashed can be found in the error message.

Where can I get more info about Adobe Flash crashes?

See Adobe Flash plugin has crashed - Prevent it from happening again.

Developing for Flash with Flex?

Breakpoints can trigger Firefox's hang protection. You can disable hang protection by setting the dom.ipc.plugins.timeoutSecs preference to -1. See the Mozilla Developer Network documentation for details.

Share this article: http://mzl.la/1xKrNYS

Was this article helpful?




Based on the above, it can be reasonably assumed that a conflict between the most recent versions of Adobe Flashplayer & the most recent versions of Mozilla are conflicting with the TCM ON-DEMAND webpage and apparently are causing the problems that result in the "buffering" (little circle) and movie screen "black-out" that I/we are experiencing.


Addendum NOTE: I have learned to always use the "Private Browsing" features and my browsing settings are to automatically clear all cookies, etc. upon exiting the browser. I always use a fresh browser with nothing else on it except the TCM ON-DEMAND webpage when attempting to watch a video this way, so there should be no other add-ins working at that time except for the necessary Flashplayer plugin. I generally check speedtest.net before starting a movie, and after experiencing any problems to see if download speed could be a factor. Aside from making sure that my provider is doing their job (COX) and my modem is functioning as it should, that, the remaining primary variables affecting viewing a movie on TCM ON-DEMAND is the TCM webpage, the Mozilla browser, and the Adobe Flash player.

Link to post
Share on other sites
  • 3 weeks later...

I am chiming in here to report that I now have this same issue with firefox and flash but I am using Linux Mint17.3. It had been working successfully for a year or more.  I dont usually bother watching TCM movies on demand in my Linux computer since I have a few windows/firefox set ups which have been working fine for some long time.

I get all these same symptoms you've detailed nicely in your posts. no clue as to reasons either

I had encountered issues with fox fire and Mint 18.1 recently and never got it working, still not and i added another issue to the mix when I bought a new graphics card AMD RX480--forget about it. it isnt supported to any great extent and since I never got turner classics to play in mint 18 i bagged the idea totally.

thing is , I can watch any and all other html5 and flash sites from youtube, netflix, tubi tv, acorn tv, amazon. ...in my linux mint 17, 18 and windows 7 and windows 10. only issues with turner and firefox now.

I am able to get chrome to play everything but turner as well. (except in Mint 18)

just adding my contributions to this thread

I had posted my own questions and an answer or so in the past 2 or more years here

with windows 7 and firefox there has always been some resolution after a period of time. from days to months though and i never found out what fixed it or what caused the failures , spinning wheel or whatever the thing is.

I am, now, not even getting the flash error messages you've graciously posted . I had those issues before and, now, I dont even get that far(in linux )

I am hoping I dont go to my windows computer to experience this stuff all over again.

last used it yesterday-in windows- and it's been down in my linux machines at least a month,could be more since i do not check much.but and without my windows 10 machine indefinitely , so found i have the issue with mint, 17.3 again. i tried all kinds of things too

reinstall, updates, alternatives that may be too boring to list here though i will share should anyone be interested in linux things, but since they havent worked, no point now.

thanks for your extremely detailed and organized posts


Link to post
Share on other sites
  • 2 weeks later...

I know my way around computers.  I solve others' computer problems at work.  Yet I am totally flummoxed when it comes to why TCM Watch Now works on my android device, works on my iPhone, but does not work on a Win 10, Win 7, Linux Mint 17.x, Ubuntu machine.  Unless, of course, TCM, which is run by Time Warner, is as --- oh, wait, that explains everything.


Don't expect a fix.  They're Time Warner.  They don't have to fix.

Link to post
Share on other sites

I was bored with the topics so I scrolled down.  Interesting to see so many using a combination of either Firefox or Linux or both.  I thought most here were either using Windows XP or Windows 10. :P


Looking around, I found this:



Going to v. 49.0 I see this:

  • Improved video performance for users on systems that support SSSE3 without hardware acceleration
  • Ended Firefox for Windows support for SSE processors

So if your computer is not at least a Duo-core, it looks like Firefox will not be supporting it anymore.  I went from an old PIII to a Duo-core to remedy this 2-3 years ago with VideoRedo, which has a 3rd party component which no longer supported SSE.  That is now a stand-alone Windows 7, 4-core i5 machine that doesn't have any wired connection or wireless network cards.  Anything I have that actually goes on the Internet is now Linux.


You can verify processor flags in Linux by entering "inxi -Fxxx" into a terminal window and looking at the processor flags section.  You should at least see the SSE flag, as well as any succeeding ones (sse2, sse3, sse4, etc), if your processor is newer than that.


In addition to Firefox not supporting the older SSE processor flag, maybe there is a plugin which is no longer using it either (i.e. whatever it is TCM is using).


I see Stephan55 has newer equipment, but you might want to look through that linked webpage to see if there might be support for any other dependency which changed around that time.




Beginning with around Firefox 50, there was the introduction of a different way of running the plugins in a multiprocess environment outside of the host environment, Electrolysis (e10s).  This is for stability, so that if and when add-ons crash, it won't bring down the whole browser.  Firefox did a soft adoption of this model in late 2016, releasing it to everyone but not activating it for everyone.  That may cause conflicts with 32 bit add-ons, which would disable it from running.


Type in "about:support" in FF and look for "Multiprocess Windows" to see if it is disabled or not.  That might be a possibility.


Type in "about:config" and search for "browser.tabs.remote.autostart".  You should see two entries.  One is automatically entered and the other is for manually disabling it I think.  If either is False, then there might be a plug-in that is not 64-bit or is otherwise non-compliant with the multiprocess scheme.




One more thought, maybe multicore processors are still affecting the stability of Firefox.  I noticed this back when I switched from using a single core XP computer to a multicore Windows 7 machine - rather late in the game.  Firefox was still only offered as a single-core process program for Windows, and might still be today, although for Linux it is x64.  Right around the time M$ started its BS of rolling out Windows 10.  Just before and during that time, Firefox started crashing for me, so after some BS I started using a small program "procaffx64.exe", which was floating around, to assign processor affinity to the program.  It was called from the shortcut, something like [procaffx64.exe firefox 00] or maybe [procaffx64.exe firefox 01] to tell it to use only the first core.  I don't have the exact syntax on hand.


In Linux that is super-easy.  Just change the command in the shortcut from [firefox %u] to [taskset 01 firefox %u], or perhaps [taskset 01 "firefox" %u] (for shortcuts that have a path or more than just a one-word program name).  This would assign it to just the first core of the processor.  I still use single-core affinity on my Linux Firefox browser to this day, but have forgotten why.  It just works so I'm not thinking of touching it.


The real problems with Firefox started shortly after they fired their CEO for donating $1000 or so to some political cause they disagreed with, or some happy horsesheisse like that.  He can now be found at Brave.com, working on a new browser.




That's all I have off the top of my head for now.  I haven't actually attempted to use the streaming services myself.  I figured I'd just go with the flow and capture it from the Directv DVR, as it airs, circumventing any Directv DVR playback issues that may or may not exist.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
© 2021 Turner Classic Movies Inc. A Time Warner Company. All Rights Reserved Terms of Use | Privacy Policy | Cookie Settings
  • Create New...